summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tc-play/files/tc-play-3.3-ldflags.patch')
-rw-r--r--app-crypt/tc-play/files/tc-play-3.3-ldflags.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-crypt/tc-play/files/tc-play-3.3-ldflags.patch b/app-crypt/tc-play/files/tc-play-3.3-ldflags.patch
new file mode 100644
index 000000000000..5976ecdd4d81
--- /dev/null
+++ b/app-crypt/tc-play/files/tc-play-3.3-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.classic
++++ b/Makefile.classic
+@@ -84,7 +84,7 @@ all: tcplay libtcplay.so libtcplay.a
+ $(CC) $(COMMON_CFLAGS) $(CFLAGS) -c -o $@ $<
+
+ tcplay: $(OBJS_PROG)
+- $(CC) $(COMMON_CFLAGS) $(CFLAGS) -o tcplay $(OBJS_PROG) $(LIBS)
++ $(CC) $(COMMON_CFLAGS) $(CFLAGS) -o tcplay $(LDFLAGS) $(OBJS_PROG) $(LIBS)
+
+ libtcplay.so.$(MAJ_VER).$(MIN_VER): $(OBJS_LIB)
+ $(CC) -shared -Wl,-version-script=tcplay.map -Wl,-soname=libtcplay.so.$(MAJ_VER).$(MIN_VER) $(LDFLAGS) \