summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/files/qca-2.1.3-deps.patch38
-rw-r--r--app-crypt/qca/qca-2.1.3-r2.ebuild1
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/qca/files/qca-2.1.3-deps.patch b/app-crypt/qca/files/qca-2.1.3-deps.patch
new file mode 100644
index 000000000000..e1ef2e5c0e7e
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.1.3-deps.patch
@@ -0,0 +1,38 @@
+From e854f357f4037e2c8c781ebd04ec5164a882b9b3 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 12 Apr 2018 00:45:50 +0200
+Subject: [PATCH] Make Qt5Network conditional on BUILD_TESTS
+
+Summary: I did not find it in use somewhere else.
+
+Reviewers: iromanov, sitter, rjvbb
+
+Reviewed By: rjvbb
+
+Subscribers: fvogt
+
+Differential Revision: https://phabricator.kde.org/D12129
+---
+ CMakeLists.txt | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 28b0169..65b95f8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -59,7 +59,11 @@ if (Qt5Core_FOUND)
+ message(STATUS "Building with Qt5 support")
+ # Got from ECM
+ # Distros have no ECM. So I just copied required cmake modules.
+- find_package(Qt5Transitional REQUIRED Core Network)
++ if(BUILD_TESTS)
++ find_package(Qt5Transitional REQUIRED Core Network)
++ else()
++ find_package(Qt5Transitional REQUIRED Core)
++ endif()
+ include(ECMQt4To5Porting)
+
+ include(GNUInstallDirs)
+--
+2.17.1
+
diff --git a/app-crypt/qca/qca-2.1.3-r2.ebuild b/app-crypt/qca/qca-2.1.3-r2.ebuild
index d93996ca867b..a1d5bbb0df5f 100644
--- a/app-crypt/qca/qca-2.1.3-r2.ebuild
+++ b/app-crypt/qca/qca-2.1.3-r2.ebuild
@@ -50,6 +50,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-disable-pgp-test.patch"
"${FILESDIR}/${P}-c++11.patch"
+ "${FILESDIR}/${P}-deps.patch"
)
qca_plugin_use() {