summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/tldp-howto/tldp-howto-20120707.ebuild')
-rw-r--r--app-doc/tldp-howto/tldp-howto-20120707.ebuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/app-doc/tldp-howto/tldp-howto-20120707.ebuild b/app-doc/tldp-howto/tldp-howto-20120707.ebuild
index 4fe2b10bbaec..38effcf91210 100644
--- a/app-doc/tldp-howto/tldp-howto-20120707.ebuild
+++ b/app-doc/tldp-howto/tldp-howto-20120707.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="The Linux Documentation Project HOWTOs"
HOMEPAGE="http://www.tldp.org"
@@ -19,43 +19,53 @@ KEYWORDS="~alpha amd64 arm hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="+html htmlsingle pdf text"
REQUIRED_USE="|| ( html htmlsingle pdf text )"
-DEPEND=""
-RDEPEND="${DEPEND}"
-
RESTRICT="binchecks strip"
src_unpack() {
mkdir -p "${S}" || die
- cd "${S}"
+ cd "${S}" || die
+
if use html; then
unpack Linux-html-HOWTOs-${PV}.tar.bz2
+
# for some reason this bundles the pdfs - older versions didn't
- [[ -d ${S}/HOWTO/pdf ]] && rm -r "${S}"/HOWTO/pdf
+ if [[ -d "${S}"/HOWTO/pdf ]] ; then
+ rm -r "${S}"/HOWTO/pdf || die
+ fi
+
# stray bin file, doubt anyone will ever need it
- rm -f "${S}"/HOWTO/RedHat-CD-HOWTO/rhcd-scripts/rvc
- mv "${S}"/HOWTO "${S}"/html
+ rm -f "${S}"/HOWTO/RedHat-CD-HOWTO/rhcd-scripts/rvc || die
+ mv "${S}"/HOWTO "${S}"/html || die
fi
+
if use htmlsingle; then
mkdir "${S}"/htmlsingle || die
- pushd "${S}"/htmlsingle > /dev/null
+ pushd "${S}"/htmlsingle > /dev/null || die
+
unpack Linux-html-single-HOWTOs-${PV}.tar.bz2
- popd > /dev/null
+
+ popd > /dev/null || die
fi
+
if use pdf; then
mkdir "${S}"/pdf || die
- pushd "${S}"/pdf > /dev/null
+ pushd "${S}"/pdf > /dev/null || die
+
unpack Linux-pdf-HOWTOs-${PV}.tar.bz2
- popd > /dev/null
+
+ popd > /dev/null || die
fi
+
if use text; then
mkdir "${S}"/text || die
- pushd "${S}"/text > /dev/null
+ pushd "${S}"/text > /dev/null || die
+
unpack Linux-HOWTOs-${PV}.tar.bz2
- popd > /dev/null
+
+ popd > /dev/null || die
fi
}
src_install() {
- insinto /usr/share/doc/${PF}
- doins -r "${S}"/*
+ dodoc -r "${S}"/*
}