summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/curses-hexedit')
-rw-r--r--app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
index 4ba0ace025b7..0d5772286225 100644
--- a/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
+++ b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# There's already a "hexedit" package in the tree, so name this one differently
-EAPI="4"
+EAPI="5"
+
+inherit toolchain-funcs
MY_P=${P/curses-}
DESCRIPTION="full screen curses hex editor (with insert/delete support)"
@@ -16,11 +18,14 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="sys-libs/ncurses"
+RDEPEND="sys-libs/ncurses:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_configure() {
+ # Package has an old configure script.
+ CONFIG_SHELL="/bin/bash"
+ tc-export CC
econf --program-prefix=curses-
}