summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-5.2.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index e1547160876a..9cdab2674317 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,4 +1,3 @@
DIST nano-4.9.3.tar.gz 2999198 BLAKE2B a96f707936934a965a9a41dfe13ac1ebbe1a5e38db714df6d219b2c6539f24924d4c4f0451508718f66259854806032b84dc89850a7fd55d157f28ae23531d0e SHA512 233e6ed103441bd2c85ed21c50547f85dc0838cc750a5e9b16ecfb393e3b7b978e971af4a4164062c7c267c98895ecb696c02cbd2e4c2eb1ceee657fd026c30a
-DIST nano-5.2.tar.gz 2865091 BLAKE2B 3822b3fd8dede897d698401a06ea0b4b49bf39f48d16c750e273007b1795a8adfc71654eadc08039a5c6999973ff7e70148b4c720b32a8f361424404e3c2ff3f SHA512 4c77bcfdf704a7882e944cb6d4cd571b698447500255e5701d30990def56cec0c396a33c761b8149f3cc4208a8dcd0f39372804d54cbe6bc2db9244f4a2259b3
DIST nano-5.3.tar.gz 2874796 BLAKE2B d266018f2508153369e10c6f9cf4c53eaeafdf0efe88da6de19efd76ef13fedebe4b9339ae594b751a12cf18a8c4dcd57466ceedfabf61406f63b69c75fceff1 SHA512 019b58779f5a7d9a9472b415715876d0daac313a02b794900339469ee0b5a27ce202e397c00ad6396b7e26a7c303e52c28d981fff85cf774c79a5a8a9835836d
DIST nano-5.4.tar.gz 2898561 BLAKE2B 7e5e48f1e85253a7a4a9be2be2b7663e8798655d9e9e2505df1d1752512058734062af953652c1d11dca464ca06d7c90faf2e54cdb65ba01d0f76cfca0282c18 SHA512 711b1a890649e3a2b62c778e6d54813ed98a8261c47a92aa6d7baa690f86d8563813a764f5dffcc6c259fe9b05f8fe76cf48a3178b09666ba55ee035c91cbe28
diff --git a/app-editors/nano/nano-5.2.ebuild b/app-editors/nano/nano-5.2.ebuild
deleted file mode 100644
index 86f22534c12f..000000000000
--- a/app-editors/nano/nano-5.2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
- inherit git-r3 autotools
-else
- MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell +split-usr static unicode"
-
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
- sys-libs/ncurses:0=[static-libs(+)]
- magic? ( sys-apps/file[static-libs(+)] )
- nls? ( virtual/libintl )
- !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-REQUIRED_USE="!ncurses? ( slang? ( minimal ) )"
-
-src_prepare() {
- default
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --htmldir=/trash
- $(use_enable !minimal color)
- $(use_enable !minimal multibuffer)
- $(use_enable !minimal nanorc)
- $(use_enable magic libmagic)
- $(use_enable spell speller)
- $(use_enable justify)
- $(use_enable debug)
- $(use_enable nls)
- $(use_enable unicode utf8)
- $(use_enable minimal tiny)
- $(usex ncurses --without-slang $(use_with slang))
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- # don't use "${ED}" here or things break (#654534)
- rm -r "${D}"/trash || die
-
- dodoc doc/sample.nanorc
- docinto html
- dodoc doc/faq.html
- insinto /etc
- newins doc/sample.nanorc nanorc
- if ! use minimal ; then
- # Enable colorization by default.
- sed -i \
- -e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
-
- # Since nano-5.0 these are no longer being "enabled" by default
- # (bug #736848)
- local rcdir="/usr/share/nano"
- mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
- rmdir "${ED}"${rcdir}/extra || die
- fi
-
- use split-usr && dosym ../../bin/nano /usr/bin/nano
-}