summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vis/vis-0.5.ebuild')
-rw-r--r--app-editors/vis/vis-0.5.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/app-editors/vis/vis-0.5.ebuild b/app-editors/vis/vis-0.5.ebuild
deleted file mode 100644
index e7cf08742d4e..000000000000
--- a/app-editors/vis/vis-0.5.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PTV=0.3
-
-DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
-HOMEPAGE="https://github.com/martanne/vis"
-SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/vis-v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/martanne/vis-test/releases/download/v${MY_PTV}/vis-test-${MY_PTV}.tar.gz -> vis-test-${MY_PTV}.tar.gz )"
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="+ncurses selinux test tre"
-RESTRICT="!test? ( test )"
-
-#Note: vis is reported to also work with NetBSD curses
-#TODO: >=dev-lang/lua-5.2 (needed for syntax highlighting and settings)
-DEPEND="dev-libs/libtermkey
- ncurses? ( sys-libs/ncurses:0= )
- tre? ( dev-libs/tre:= )"
-RDEPEND="${DEPEND}
- app-eselect/eselect-vi"
-
-S="${WORKDIR}/vis-v${PV}"
-
-src_prepare() {
- if use test; then
- rm -r test || die
- mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
- if ! type -P vim &>/dev/null; then
- sed -i 's/.*vim.*//' test/Makefile || die
- fi
-
- # https://bugs.gentoo.org/722014 https://github.com/martanne/vis-test/pull/22
- sed -i 's;./ccan-config > config.h;./ccan-config "${CC}" ${CFLAGS} > config.h;' test/core/Makefile || die
- fi
-
- sed -i 's|STRIP?=.*|STRIP=true|' Makefile || die
- sed -i 's|${DOCPREFIX}/vis|${DOCPREFIX}|' Makefile || die
- sed -i 's|DOCUMENTATION = LICENSE|DOCUMENTATION =|' Makefile || die
-
- default
-}
-
-src_configure() {
- export CFLAGS="$CFLAGS -fcommon" # https://github.com/martanne/vis-test/issues/21
-
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable ncurses curses) \
- $(use_enable selinux) \
- $(use_enable tre) || die
-}
-
-update_symlinks() {
- einfo "Calling eselect vi update --if-unset"
- eselect vi update --if-unset
-}
-
-pkg_postrm() {
- update_symlinks
-}
-
-pkg_postinst() {
- update_symlinks
-}