summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/emacs-28.0.9999.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-editors/emacs/emacs-28.0.9999.ebuild b/app-editors/emacs/emacs-28.0.9999.ebuild
index aeefea10ed81..4a6795ce8017 100644
--- a/app-editors/emacs/emacs-28.0.9999.ebuild
+++ b/app-editors/emacs/emacs-28.0.9999.ebuild
@@ -141,9 +141,16 @@ src_prepare() {
|| die "Upstream version number changed to ${FULL_VERSION}"
fi
- # These files ignore LDFLAGS. We assign the variable here, because
- # for live ebuilds FULL_VERSION doesn't exist in global scope
- use jit && QA_FLAGS_IGNORED="usr/$(get_libdir)/emacs/${FULL_VERSION}/native-lisp/.*"
+ if use jit; then
+ # These files ignore LDFLAGS. We assign the variable here, because
+ # for live ebuilds FULL_VERSION doesn't exist in global scope
+ QA_FLAGS_IGNORED="usr/$(get_libdir)/emacs/${FULL_VERSION}/native-lisp/.*"
+ # gccjit doesn't play well with ccache #801580
+ # For now, work around the problem with an explicit LIBRARY_PATH
+ has ccache ${FEATURES} \
+ && export LIBRARY_PATH=$("$(tc-getCC)" -print-search-dirs \
+ | sed -n '/^libraries:/{s:^[^/]*::;p}')
+ fi
default