summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/files/nano-4.0-variable_initialization.patch39
-rw-r--r--app-editors/nano/nano-4.0-r1.ebuild85
3 files changed, 0 insertions, 125 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 8b692af14c15..46a5796874f8 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,4 +1,3 @@
DIST nano-3.2.tar.gz 2944045 BLAKE2B 8d29d574ebf543f82608d4df26f551c0b3c77863b2ac8cfd0d3aea45340954abe6221069c9c72beab256c2c8cc4fcd3de27804404d97a98144c69ad26223de09 SHA512 33b3bbc5b5044b4003347e87926046fb5a0e83edfd6de858085526b7eaa9ea7ee26a598da00060a6b62edbd0366c7cb06b5a9878f6f0149a9501e4ada80b88f3
-DIST nano-4.0.tar.gz 2997716 BLAKE2B b5b7c172119518dc25ad1b77fda4a011225292b36bfeb042ede3191f7b7d576273c9172c9ab32271b4a648d8720c3745496526f0feb871e02d88ae3865cfacd5 SHA512 7548a3cf37aaa5f7ed9e951c18b3d058e8f587bcfbae0e707668f51ab9932aa467b8191117a7d1a76f090124cfe3e0e93ce4e1cccd8aa0bf7fd0d282caede5c1
DIST nano-4.1.tar.gz 2918354 BLAKE2B 6f5438b2e4bb9a6de405a7519d1767697df1504e67aae37a75743b658b82d9bf13e0b561177415445827f8a63456afd4f689b1d34b6a3eb53c940972fa01f93d SHA512 982b845197aa2942eb8a49b2ac1bfd8cc65ec9b6b7f60190059367b4f9156b4f0bb5e56a123f0659b23c6c9d1d85733123350a8f04c433ccb32d4c8ef1135d12
DIST nano-4.2.tar.gz 2928595 BLAKE2B 42bb0ccbf4961706c6c645eb2310a646a7decd3617117a079ffe9e3718c8054ab823a5aff3e543c06c4c398f83579a679267a9ad6f113ba451b76d67e14b07cc SHA512 a5dd9ce96cd09d12c65108ea6a18b2cf1c2b055929e58d3e84beb0725607b4b5a3f8ae3fda0ab658c853cc4cac70c089fee716e1bb5a700f2506a7a3e1bea1bd
diff --git a/app-editors/nano/files/nano-4.0-variable_initialization.patch b/app-editors/nano/files/nano-4.0-variable_initialization.patch
deleted file mode 100644
index c72122ed7035..000000000000
--- a/app-editors/nano/files/nano-4.0-variable_initialization.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 7ad232d71470cd8c4dc63aeb02f11c9e8df9ecdb Mon Sep 17 00:00:00 2001
-From: Devin Hussey <husseydevin@gmail.com>
-Date: Thu, 28 Mar 2019 17:28:47 -0400
-Subject: [PATCH] files: initialize a variable before referencing it
-
-The lack of initialization caused a nasty bug on some targets (such as
-ARMv7) which would make it so that ^S would just say "Cancelled".
-
-While x86 (both 64 and 32 bits) seems to initialize 'response' to zero or
-a positive number, ARM does not, and there is usually a negative value in
-its place, which triggers the 'if (response < 0)' check and, as a result,
-the code says "Cancelled".
-
-This fixes https://savannah.gnu.org/bugs/?56023.
-Reported-by: Devin Hussey <husseydevin@gmail.com>
-
-Bug existed since version 4.0, commit 0f9d60a3.
-
-Signed-off-by: Devin Hussey <husseydevin@gmail.com>
----
- src/files.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/files.c b/src/files.c
-index 84e3f684..fd54c168 100644
---- a/src/files.c
-+++ b/src/files.c
-@@ -2101,7 +2101,7 @@ int do_writeout(bool exiting, bool withprompt)
-
- while (TRUE) {
- const char *msg;
-- int response, choice;
-+ int response = 0, choice = 0;
- functionptrtype func;
- #ifndef NANO_TINY
- const char *formatstr, *backupstr;
---
-2.20.1
-
diff --git a/app-editors/nano/nano-4.0-r1.ebuild b/app-editors/nano/nano-4.0-r1.ebuild
deleted file mode 100644
index 05e4012530b3..000000000000
--- a/app-editors/nano/nano-4.0-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
- inherit git-r3 autotools
-else
- MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
-
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
- sys-libs/ncurses:0=[static-libs(+)]
- magic? ( sys-apps/file[static-libs(+)] )
- nls? ( virtual/libintl )
- !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-variable_initialization.patch"
-)
-
-src_prepare() {
- default
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --htmldir=/trash
- $(use_enable !minimal color)
- $(use_enable !minimal multibuffer)
- $(use_enable !minimal nanorc)
- $(use_enable magic libmagic)
- $(use_enable spell speller)
- $(use_enable justify)
- $(use_enable debug)
- $(use_enable nls)
- $(use_enable unicode utf8)
- $(use_enable minimal tiny)
- $(usex ncurses --without-slang $(use_with slang))
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- # don't use "${ED}" here or things break (#654534)
- rm -r "${D}"/trash || die
-
- dodoc doc/sample.nanorc
- docinto html
- dodoc doc/faq.html
- insinto /etc
- newins doc/sample.nanorc nanorc
- if ! use minimal ; then
- # Enable colorization by default.
- sed -i \
- -e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
- fi
-
- dosym ../../bin/nano /usr/bin/nano
-}