summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/emacs-openrc/emacs-openrc-9999.ebuild')
-rw-r--r--app-emacs/emacs-openrc/emacs-openrc-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild b/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild
new file mode 100644
index 000000000000..bc1c4a983f82
--- /dev/null
+++ b/app-emacs/emacs-openrc/emacs-openrc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="OpenRC integration for GNU Emacs"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-openrc.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}