summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/s/s-1.12.0-r1.ebuild')
-rw-r--r--app-emacs/s/s-1.12.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/s/s-1.12.0-r1.ebuild b/app-emacs/s/s-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..7c91889d847b
--- /dev/null
+++ b/app-emacs/s/s-1.12.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="The long lost Emacs string manipulation library"
+HOMEPAGE="https://github.com/magnars/s.el"
+SRC_URI="https://github.com/magnars/s.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/s.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ sh run-tests.sh || die
+}