summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20170917.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20170917.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20170917.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20170917.ebuild
new file mode 100644
index 000000000000..0550a4eed8f1
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20170917.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="7b2b1feb1de4817d522cc372af149ff48d25028e"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="https://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}