summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker/docker-9999.ebuild')
-rw-r--r--app-emulation/docker/docker-9999.ebuild34
1 files changed, 15 insertions, 19 deletions
diff --git a/app-emulation/docker/docker-9999.ebuild b/app-emulation/docker/docker-9999.ebuild
index 4b3fc942264d..0667345ad26a 100644
--- a/app-emulation/docker/docker-9999.ebuild
+++ b/app-emulation/docker/docker-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGO_PN="github.com/docker/docker"
@@ -10,17 +10,17 @@ if [[ ${PV} = *9999* ]]; then
# Docker cannot be fetched via "go get", thanks to autogenerated code
EGIT_REPO_URI="https://${EGO_PN}.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
- inherit golang-base git-r3
+ inherit git-r3
else
MY_PV="${PV/_/-}"
- DOCKER_GITCOMMIT="4dc5990"
+ DOCKER_GITCOMMIT="906eacd"
EGIT_COMMIT="v${MY_PV}"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
[ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
inherit golang-vcs-snapshot
fi
-inherit bash-completion-r1 linux-info multilib systemd udev user
+inherit bash-completion-r1 golang-base linux-info systemd udev user
DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
HOMEPAGE="https://dockerproject.org"
@@ -34,9 +34,8 @@ CDEPEND="
device-mapper? (
>=sys-fs/lvm2-2.02.89[thin]
)
- seccomp? (
- >=sys-libs/libseccomp-2.2.1[static-libs]
- )
+ seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+ apparmor? ( sys-libs/libapparmor )
"
DEPEND="
@@ -60,12 +59,8 @@ RDEPEND="
>=dev-vcs/git-1.7
>=app-arch/xz-utils-4.9
- >=app-emulation/containerd-0.2.0
- >=app-emulation/runc-0.1.0
-
- apparmor? (
- sys-libs/libapparmor[static-libs]
- )
+ >app-emulation/containerd-0.2.2
+ app-emulation/runc[apparmor?,seccomp?]
"
RESTRICT="installsources strip"
@@ -75,7 +70,7 @@ CONFIG_CHECK="
~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
~DEVPTS_MULTIPLE_INSTANCES
~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
- ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~KEYS ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
~NF_NAT ~NF_NAT_NEEDED
@@ -91,6 +86,7 @@ CONFIG_CHECK="
~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
"
+ERROR_KEYS="CONFIG_KEYS: is mandatory"
ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
@@ -172,9 +168,10 @@ pkg_setup() {
src_prepare() {
cd "src/${EGO_PN}" || die
- epatch "${FILESDIR}/docker-containerd.patch"
+ sed -i 's/docker-containerd/containerd/g; s/docker-runc/runc/g' libcontainerd/remote_linux.go
# allow user patches (use sparingly - upstream won't support them)
- epatch_user
+ cd -
+ eapply_user
}
src_compile() {
@@ -229,9 +226,8 @@ src_compile() {
src_install() {
cd "src/${EGO_PN}" || die
VERSION="$(cat VERSION)"
- newbin "bundles/$VERSION/dynbinary/docker-$VERSION" docker
- #exeinto /usr/libexec/docker
- #newexe "bundles/$VERSION/dynbinary/dockerinit-$VERSION" dockerinit
+ newbin "bundles/$VERSION/dynbinary-client/docker-$VERSION" docker
+ newbin "bundles/$VERSION/dynbinary-daemon/dockerd-$VERSION" dockerd
newinitd contrib/init/openrc/docker.initd docker
newconfd contrib/init/openrc/docker.confd docker