summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/rex-client/rex-client-9999.ebuild')
-rw-r--r--app-emulation/rex-client/rex-client-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/rex-client/rex-client-9999.ebuild b/app-emulation/rex-client/rex-client-9999.ebuild
new file mode 100644
index 000000000000..8eea78563fc8
--- /dev/null
+++ b/app-emulation/rex-client/rex-client-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Remote EXexcution agent"
+HOMEPAGE="http://mduft.github.io/rex/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mduft/rex.git"
+else
+ SRC_URI=""
+ KEYWORDS="~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+REX_EXE=(
+ "client/rex-exec.sh"
+ "client/rex-register.sh"
+ "client/rex-paths.sh"
+ "client/rex-remote-pconv.sh"
+ "client/winpath2unix"
+ "client/unixpath2win"
+ )
+
+src_prepare() {
+ for x in ${REX_EXE[@]}; do
+ sed \
+ -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" \
+ -i "${x}" || die
+ done
+}
+
+src_install() {
+ for x in ${REX_EXE[@]}; do
+ dobin "${S}"/${x}
+ done
+
+ insinto /etc
+ newins client/rex-config.sh rex.conf
+}