summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vice/files/vice-2.4-arm.patch')
-rw-r--r--app-emulation/vice/files/vice-2.4-arm.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/vice/files/vice-2.4-arm.patch b/app-emulation/vice/files/vice-2.4-arm.patch
new file mode 100644
index 000000000000..55e2d5a35b0c
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4-arm.patch
@@ -0,0 +1,38 @@
+--- vice/configure.in
++++ vice/configure.in
+@@ -2299,6 +2299,7 @@
+
+ if test x"$PARSID_SUPPORT" = "xno"; then
+ AC_CHECK_FUNCS(ioperm,[PARSID_SUPPORT=yes],)
++ AC_CHECK_FUNCS(outb_p inb_p)
+ fi
+
+ if test x"$PARSID_SUPPORT" = "xyes"; then
+--- vice/src/arch/unix/parsid.c
++++ vice/src/arch/unix/parsid.c
+@@ -217,8 +217,12 @@
+ #endif
+ #endif
+ #ifdef HAVE_IOPERM
++#ifndef HAVE_OUTB_P
++ outb(value, addr);
++#else
+ outb_p(value, addr);
+ #endif
++#endif
+ }
+
+ BYTE parsid_inb(int addr)
+@@ -237,8 +241,12 @@
+ #endif
+ #endif
+ #ifdef HAVE_IOPERM
++#ifndef HAVE_INB_P
++ return inb((unsigned short)addr);
++#else
+ return inb_p((unsigned short)addr);
+ #endif
++#endif
+ }
+
+ /* chip control pin assignments */