summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/Manifest1
-rw-r--r--app-emulation/vice/vice-3.1.ebuild178
2 files changed, 179 insertions, 0 deletions
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 6e784a30e2b9..ff495dc9e4d2 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,3 +1,4 @@
DIST vice-2.4.22.tar.gz 25180343 BLAKE2B 9c48539b0ec1604a196211819c43c7cdba970cee404b64fbaa1957bb8167ae9f7f108ba0f54ef0ef82314331694dfc5f6bca0d569ee940d6531ed49cd7bb2ffa SHA512 b43e609ae2f43717d10e079d3b8ac284e5c4920ed222c7502e9a7b75dfe32784628031ae6cf8672c8d9d50576fb714cecdd1a9292bf53477f4bbd52c10403975
DIST vice-2.4.27.tar.gz 25561665 BLAKE2B 36e8460ef1e4aed9f83caf2b46924766d6830368c947ddfee68ecf992685f950db9e433238b61c34691dadb719ede4e9c5cc7104279e06140e347b04eb8a97a3 SHA512 589b9892f3180db6f169e74b863171f08567045862f2f47cac73ef946e81d55dcde5373fc910cfd1659238669f12ee6ad934c7143c87fad736cda77479439bec
DIST vice-2.4.31.tar.gz 25898329 BLAKE2B 113be451d322f21488f23711ce971ff7a83538d3dfd516138fec84f27e4933025bbba8cbbc627111aadad437ab7805491286760b4fe9db915307922d00dba27f SHA512 eebd25fb808b1837ea8d76b1399d3d7ed80a66ae206ea3e0d51fe0fb9df21f3bfeb3fbe353c1022e02754987116e33d4c6888e61448b3250ebefbbfe1b854e94
+DIST vice-3.1.tar.gz 30714226 BLAKE2B 75c2cce5294dad5b954cd23b623b6b4610c8142a09aef05dbefed6b3e6b268077d375e644dde6a057682d41ab9cf15e93a9f4a9359bfa0d1567d6d1862053a0e SHA512 bc02a3597a17dadb37c487e6942192c0e9dc1a7d4e440fbf0dc8a165dbb2dee60ddf157697a020d2780ddef56a0a67802768d5c6d117b9cf5cdc124de45bc579
diff --git a/app-emulation/vice/vice-3.1.ebuild b/app-emulation/vice/vice-3.1.ebuild
new file mode 100644
index 000000000000..113100eec804
--- /dev/null
+++ b/app-emulation/vice/vice-3.1.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://vice-emu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vice-emu/releases/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="Xaw3d alsa ethernet ffmpeg fullscreen +gtk ipv6 lame libav nls oss png pulseaudio sdl +sdlsound threads vte zlib"
+
+# upstream says gtk3 and sdl2 shouldn't be exposed yet.
+#REQUIRED_USE="?? ( gtk2 gtk3 sdl )"
+REQUIRED_USE="?? ( gtk sdl )"
+
+GTK_COMMON="
+ x11-libs/pango
+ x11-libs/cairo"
+# gtk3? (
+# x11-libs/gtk+:3
+# vte? ( x11-libs/vte:2.90 )
+# ${GTK_COMMON}
+# )
+RDEPEND="
+ virtual/jpeg:0
+ virtual/opengl
+ media-libs/giflib
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdlsound? ( media-libs/libsdl[sound] )
+ ethernet? (
+ >=net-libs/libpcap-0.9.8
+ >=net-libs/libnet-1.1.2.1:1.1
+ )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
+ )
+ lame? ( media-sound/lame )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng:0= )
+ zlib? ( sys-libs/zlib:= )
+ sdl? (
+ media-libs/libsdl[joystick,video]
+ )
+ !sdl? (
+ x11-libs/libX11
+ x11-libs/libXext
+ sys-libs/readline:0=
+ fullscreen? (
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ !gtk? (
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libXv
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ ${GTK_COMMON}
+ vte? ( x11-libs/vte:0 )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ x11-proto/xproto
+ x11-proto/xextproto
+ media-libs/fontconfig
+ x11-proto/videoproto
+ nls? ( sys-devel/gettext )
+ !sdl? (
+ fullscreen? (
+ x11-proto/xf86vidmodeproto
+ )
+ !gtk? (
+ x11-libs/libICE
+ x11-libs/libSM
+ )
+ )"
+
+PATCH=(
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/building//' \
+ doc/Makefile.am || die
+ sed -i \
+ -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}:" \
+ doc/Makefile.am \
+ doc/readmes/Makefile.am || die
+ sed -i \
+ -e "/^docdir =/s:=.*:=/usr/share/doc/${PF}/html:" \
+ doc/html/Makefile.am || die
+ sed -i \
+ -e "s:/usr/local/lib/VICE:/usr/$(get_libdir)/${PN}:" \
+ man/vice.1 \
+ $(grep -rl --exclude="*texi" /usr/local/lib doc) || die
+ sed -i \
+ -e "/VICEDIR=/s:=.*:=\"/usr/$(get_libdir)/${PN}\";:" \
+ configure.ac || die
+ sed -i \
+ -e "s:\(#define LIBDIR \).*:\1\"/usr/$(get_libdir)/${PN}\":" \
+ -e "s:\(#define DOCDIR \).*:\1\"/usr/share/doc/${PF}\":" \
+ src/arch/unix/archdep.h \
+ src/arch/sdl/archdep_unix.h || die
+ rm -rf src/lib/{libffmpeg,liblame} || die
+ sed -i \
+ -e '/SUBDIRS/s/libffmpeg//;' \
+ -e '/SUBDIRS/s/liblame//;' \
+ src/lib/Makefile.am || die
+ AT_NO_RECURSIVE=1 eautoreconf
+}
+
+src_configure() {
+ local gui_arg=() snd_arg=()
+
+ snd_arg+=( $(use_with alsa) )
+ snd_arg+=( $(use_with oss) )
+ snd_arg+=( $(use_with pulseaudio pulse) )
+ snd_arg+=( $(use_with sdlsound) )
+
+ gui_arg+=( $(use_enable sdl sdlui) )
+ # The gtk UI code has raw calls to XOpenDisplay and
+ # is missing -lX11 if vte doesn't pull it in.
+ #if use gtk2 || use gtk3 ; then
+ if use gtk ; then
+ use vte || append-libs -lX11
+ fi
+ gui_arg+=( $(use_enable gtk gnomeui) )
+ #gui_arg+=" $(use_enable gtk3 gnomeui3)"
+ gui_arg+=( $(use_enable Xaw3d xaw3d) )
+
+ # --with-readline is forced to avoid using the embedded copy
+ # don't try to actually run fc-cache (bug #280976)
+ FCCACHE=/bin/true \
+ PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ econf \
+ --enable-parsid \
+ --with-resid \
+ --with-readline \
+ --without-arts \
+ --without-midas \
+ $(use_enable ethernet) \
+ $(use_enable ffmpeg) \
+ $(use_enable ffmpeg external-ffmpeg) \
+ $(use_enable fullscreen) \
+ $(use_enable ipv6) \
+ $(use_enable lame) \
+ $(use_enable nls) \
+ $(use_enable vte) \
+ $(use_with png) \
+ $(use_with threads uithreads) \
+ $(use_with zlib) \
+ "${gui_arg[@]}" \
+ "${snd_arg[@]}" \
+ --disable-option-checking
+ # --disable-option-checking has to be last
+}
+
+src_install() {
+ default
+ dodoc FEEDBACK
+}