summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/files/vice-2.4.20-format.patch20
-rw-r--r--app-emulation/vice/vice-2.4.20.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/app-emulation/vice/files/vice-2.4.20-format.patch b/app-emulation/vice/files/vice-2.4.20-format.patch
new file mode 100644
index 000000000000..1c782fd61e5d
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.4.20-format.patch
@@ -0,0 +1,20 @@
+--- src/main.c.old 2015-10-19 17:25:07.549164652 +0200
++++ src/main.c 2015-10-19 17:25:33.106694706 +0200
+@@ -227,7 +227,7 @@
+ for (i = 0; core_team[i].name; i++) {
+ n += strlen(core_team[i].name);
+ if (n > 74) {
+- log_message(LOG_DEFAULT, tmp);
++ log_message(LOG_DEFAULT, "%s", tmp);
+ n = 0; *tmp = 0;
+ }
+ strcat(tmp, core_team[i].name);
+@@ -235,7 +235,7 @@
+ strcat(tmp, ", ");
+ } else {
+ strcat(tmp, ".");
+- log_message(LOG_DEFAULT, tmp);
++ log_message(LOG_DEFAULT, "%s", tmp);
+ }
+ }
+ lib_free(tmp);
diff --git a/app-emulation/vice/vice-2.4.20.ebuild b/app-emulation/vice/vice-2.4.20.ebuild
index 7bf597689693..1ee7dc6d33dd 100644
--- a/app-emulation/vice/vice-2.4.20.ebuild
+++ b/app-emulation/vice/vice-2.4.20.ebuild
@@ -88,6 +88,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-format.patch \
"${FILESDIR}"/${P}-xf86extensions.patch
sed -i \
-e 's/building//' \