summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-1.4.2.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-1.4.2.ebuild b/app-i18n/ibus-skk/ibus-skk-1.4.2.ebuild
new file mode 100644
index 000000000000..dae2570a578e
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit vala
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="https://github.com/ueno/ibus-skk"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+CDEPEND="app-i18n/ibus
+ >=app-i18n/libskk-1.0.2
+ x11-libs/gtk+:3
+ nls? ( virtual/libintl )"
+RDEPEND="${CDEPEND}
+ app-i18n/skk-jisyo"
+DEPEND="${CDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}