summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
index 2d05ccfaf080..8f6b101fa56f 100644
--- a/app-i18n/libhangul/libhangul-0.1.0.ebuild
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -1,15 +1,17 @@
-# Copyright 2006-2020 Gentoo Authors
+# Copyright 2006-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+inherit libtool
+
DESCRIPTION="Library for hangul input method logic, hanja dictionary"
HOMEPAGE="https://github.com/libhangul/libhangul"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0/1"
-KEYWORDS="amd64 ppc ppc64 x86"
+KEYWORDS="amd64 ~arm64 ~loong ppc ppc64 ~riscv x86"
IUSE="nls static-libs test"
RESTRICT="!test? ( test )"
@@ -20,6 +22,11 @@ RDEPEND="virtual/libiconv
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
$(use_enable nls) \