summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/Manifest1
-rw-r--r--app-office/dia/dia-0.97.3_pre20140417-r1.ebuild107
-rw-r--r--app-office/dia/files/dia-0.97.2-disable-cairo.patch19
-rw-r--r--app-office/dia/files/dia-0.97.2-png-crash.patch33
4 files changed, 0 insertions, 160 deletions
diff --git a/app-office/dia/Manifest b/app-office/dia/Manifest
index 06bd68b73e41..59116ed5aed7 100644
--- a/app-office/dia/Manifest
+++ b/app-office/dia/Manifest
@@ -1,2 +1 @@
DIST dia-0.97.3.tar.xz 5548500 SHA256 22914e48ef48f894bb5143c5efc3d01ab96e0a0cde80de11058d3b4301377d34 SHA512 34298980be930b87cb4a636344e4cb2a7e43eedc00b0969a5e446cee9b74b616fdc8c798efcb9a5832b98741f2e20632a44037b2bcb436f59591d531ef441efa WHIRLPOOL fd6b4c92cedce399705715b9726d3f5e2570c79108c241f34afaacd54b9318e6b79e6fedcb83502b948e1eaf2157cd4429cd8ffca24a854efd3c94db4f192798
-DIST dia-0.97.3_pre20140417.tar.xz 5393236 SHA256 d9afac3b2f7bb5fa35733e24f35afd69c7b3cd04af5f6b0a806400a35b5b43db SHA512 1dbd189ca3499a5adb3c6537ffdcfc776b56fb927a3daeb266685dd4a359aa18ea9b472d12865813e823c71652f49e5739ac9d98789629a39e0cd891fe2265a6 WHIRLPOOL 28d4fcd98f853ad0dec48296a0ada9d842eb32a7953a1e11fe59fe21170be4d14e693a53e0d85c392e1b7cf4f117a3206894e3326436c5e53d115c8efb06a842
diff --git a/app-office/dia/dia-0.97.3_pre20140417-r1.ebuild b/app-office/dia/dia-0.97.3_pre20140417-r1.ebuild
deleted file mode 100644
index 14589fe1b326..000000000000
--- a/app-office/dia/dia-0.97.3_pre20140417-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG=yes
-GNOME2_LA_PUNT=yes
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils gnome2 python-single-r1 multilib
-
-DESCRIPTION="Diagram/flowchart creation program"
-HOMEPAGE="https://wiki.gnome.org/Apps/Dia"
-
-SRC_URI="https://dev.gentoo.org/~pacho/gnome/${PN}-0.97.3_pre20140417.tar.xz"
-S="${WORKDIR}/${PN}-0.97.2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
-# the doc USE flag doesn't seem to do anything without docbook2html
-# cairo support is preferred as explained by upstream at:
-# https://bugzilla.gnome.org/show_bug.cgi?id=729668#c6
-IUSE="+cairo doc python"
-
-RDEPEND="
- >=dev-libs/glib-2:2
- dev-libs/libxml2
- dev-libs/libxslt
- dev-libs/popt
- >=media-libs/freetype-2
- >=media-libs/libart_lgpl-2
- media-libs/libpng:0
- sys-libs/zlib
- x11-libs/gtk+:2
- x11-libs/pango
- cairo? ( x11-libs/cairo )
- doc? (
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets )
- python? (
- >=dev-python/pygtk-2
- ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
- dev-util/intltool
- sys-apps/sed
- virtual/pkgconfig
- doc? ( dev-libs/libxslt )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- DOCS="AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
-
- epatch "${FILESDIR}"/${PN}-0.97.0-gnome-doc.patch #159381 , upstream #470812 #558690
- epatch "${FILESDIR}"/${PN}-0.97.2-underlinking.patch #420685
- epatch "${FILESDIR}"/${PN}-0.97.2-disable-cairo.patch #509636
- epatch "${FILESDIR}"/${PN}-0.97.2-png-crash.patch #508566
-
- if use python; then
- python_fix_shebang .
- sed -i -e "s/\.so/$(get_libname)/" acinclude.m4 || die #298232
- fi
-
- if ! use doc; then
- # Skip man generation
- sed -i -e '/if HAVE_DB2MAN/,/endif/d' doc/*/Makefile.am || die
- fi
-
- # Fix naming conflict on Darwin/OSX, upstream bug #????
- sed -i -e 's/isspecial/char_isspecial/' objects/GRAFCET/boolequation.c || die
-
- sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
-
- sed -i -e "/localedir/d" configure.in || die
-
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- # --exec-prefix makes Python look for modules in the Prefix
- # --enable-gnome only adds support for deprecated stuff, bug #442294
- # https://bugzilla.redhat.com/show_bug.cgi?id=996759
- gnome2_src_configure \
- --exec-prefix="${EPREFIX}/usr" \
- --disable-gnome \
- --disable-libemf \
- $(use_enable doc db2html) \
- $(use_with cairo) \
- $(use_with python) \
- --without-swig \
- --without-hardbooks
-}
-
-src_install() {
- gnome2_src_install
-
- # Install second desktop file for integrated mode (bug #415495)
- sed -e 's|^Exec=dia|Exec=dia --integrated|' \
- -e '/^Name/ s|$| (integrated mode)|' \
- "${ED}"/usr/share/applications/dia.desktop \
- > "${ED}"/usr/share/applications/dia-integrated.desktop || die
-}
diff --git a/app-office/dia/files/dia-0.97.2-disable-cairo.patch b/app-office/dia/files/dia-0.97.2-disable-cairo.patch
deleted file mode 100644
index da07337825e9..000000000000
--- a/app-office/dia/files/dia-0.97.2-disable-cairo.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- plug-ins/cairo/Makefile.am.orig 2014-05-06 14:09:36.080876942 -0400
-+++ plug-ins/cairo/Makefile.am 2014-05-06 14:11:21.043041750 -0400
-@@ -1,11 +1,14 @@
--
-+if WITH_CAIRO
- plugin_sources = \
- diacairo.c \
- diacairo.h \
- diacairo-interactive.c \
- diacairo-renderer.c \
- diacairo-print.c \
-- diacairo-print.h
-+ diacairo-print.h
-+else
-+plugin_sources =
-+endif
-
- pkglib_LTLIBRARIES = libcairo_filter.la
-
diff --git a/app-office/dia/files/dia-0.97.2-png-crash.patch b/app-office/dia/files/dia-0.97.2-png-crash.patch
deleted file mode 100644
index 1dfc072c1c5f..000000000000
--- a/app-office/dia/files/dia-0.97.2-png-crash.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 8b8ae09fcc16cc0522679099728f779e291d959c Mon Sep 17 00:00:00 2001
-From: Hans Breuer <hans@breuer.org>
-Date: Fri, 18 Apr 2014 13:28:45 +0200
-Subject: Bug 728405 - back-port some bounding box calculation fixes from
- master
-
-... so that the unit test works without complaints.
-
-diff --git a/lib/boundingbox.c b/lib/boundingbox.c
-index fd50da7..46adbfa 100644
---- a/lib/boundingbox.c
-+++ b/lib/boundingbox.c
-@@ -494,7 +494,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
- account with the "pointy corners" X (and PS) add when LINEJOIN_MITER mode is
- in force. */
-
-- if ((!start) && (!end)) { /* We have a non-extremity vertex. */
-+ if (!end) { /* only the last segment might not produce overshoot. */
- Point vpx,vxn;
- real co,alpha;
-
-@@ -515,7 +515,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
- real overshoot;
- Point vovs,pto;
-
-- if (finite(alpha))
-+ if (alpha > 0.0 && alpha < M_PI)
- overshoot = extra->middle_trans / sin(alpha/2.0);
- else /* prependicular? */
- overshoot = extra->middle_trans;
---
-cgit v0.10.1
-