summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/Manifest4
-rw-r--r--app-office/impressive/impressive-0.13.1.ebuild (renamed from app-office/impressive/impressive-0.11.2.ebuild)42
-rw-r--r--app-office/impressive/impressive-0.13.2.ebuild (renamed from app-office/impressive/impressive-0.12.0.ebuild)39
-rw-r--r--app-office/impressive/metadata.xml2
4 files changed, 37 insertions, 50 deletions
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index ca8bf9e9161b..3602b0f0c96d 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,2 +1,2 @@
-DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
-DIST Impressive-0.12.0.tar.gz 209514 BLAKE2B aef0c793c85c680c65399cfcef56488c558ec49a8246d55bacc05a2e1fa0de51d548ddcf67788d36a4de91d62495a623269976345f99d63d25f3ae8bc9efdbd8 SHA512 3425d9d53c8c3ff6d5de0a3466bbf5c94f257390b4929ba12547ba930099de67db4f4d77d4ef4e3e10f8f723478569a74042553f64cf95e236931c7aabb70f0a
+DIST Impressive-0.13.1.tar.gz 215989 BLAKE2B 6591e5fa2c34e7e6f2283b9b6f8cce7485fc8932eea571af96c895bbe23202af195eec0318272667d5656f3aed7a88a21a20397224c7c0cc7c9252364d832371 SHA512 f6221337f9dd79f552fb083e1ea7484aeadec1f8d8e05b4e1b7f6a94037b5026022819b346968dea67dbdb1b646d0571a7aeef26f15c25bee88c5b9c2791cf2b
+DIST Impressive-0.13.2.tar.gz 294531 BLAKE2B 76b50cd1cb1366c9fed7e6f7a16142248f99e232b96b7d7372af181f3ef215aff6f3453d8fd16c2ab6fa0e7217ec831daf3ffafcb8e46ff285dc0b9d86b77839 SHA512 0b24ef39cba25d8813fd3f95f220c466defa50c3ba4a63d2f37b284de2826c2110225fe2016f58c401d1ca239d672ba28ba65069523ab57b1b5711a4222cff92
diff --git a/app-office/impressive/impressive-0.11.2.ebuild b/app-office/impressive/impressive-0.13.1.ebuild
index 14227452dabf..3b60082b1f65 100644
--- a/app-office/impressive/impressive-0.11.2.ebuild
+++ b/app-office/impressive/impressive-0.13.1.ebuild
@@ -1,41 +1,36 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-r1
-
-MY_PN="Impressive"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit optfeature python-r1
DESCRIPTION="Stylish way of giving presentations with Python"
HOMEPAGE="http://impressive.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
dev-python/pygame[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
x11-apps/xrandr
- app-text/mupdf
- || ( media-fonts/dejavu media-fonts/corefonts )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
-DOCS=(
- changelog.txt
- demo.pdf
-)
-HTML_DOCS=(
- impressive.html
-)
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
-S=${WORKDIR}/${MY_PN}-${PV}
+S="${WORKDIR}/${PN^}-${PV/_/-}"
src_install() {
default
@@ -44,9 +39,8 @@ src_install() {
}
pkg_postinst() {
- elog "The experience with ${PN} can be enhanced by folowing packages:"
optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
optfeature "sound and video playback" media-video/mplayer
- optfeature "sound and video playback" media-video/mplayer2
optfeature "extraction of PDF page titles" app-text/pdftk
}
diff --git a/app-office/impressive/impressive-0.12.0.ebuild b/app-office/impressive/impressive-0.13.2.ebuild
index 6f865b6ac5e2..7816aedb6b69 100644
--- a/app-office/impressive/impressive-0.12.0.ebuild
+++ b/app-office/impressive/impressive-0.13.2.ebuild
@@ -1,41 +1,36 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-r1
-
-MY_PN="Impressive"
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature python-r1
DESCRIPTION="Stylish way of giving presentations with Python"
HOMEPAGE="http://impressive.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV%b}/${MY_PN}-${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
dev-python/pygame[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
x11-apps/xrandr
- app-text/mupdf
- || ( media-fonts/dejavu media-fonts/corefonts )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
-DOCS=(
- changelog.txt
- demo.pdf
-)
-HTML_DOCS=(
- impressive.html
-)
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
-S=${WORKDIR}/${MY_PN}-${PV}
+S="${WORKDIR}/${PN^}-${PV/_/-}"
src_install() {
default
@@ -44,10 +39,8 @@ src_install() {
}
pkg_postinst() {
- elog "The experience with ${PN} can be enhanced by folowing packages:"
optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
optfeature "sound and video playback" media-video/ffmpeg
optfeature "sound and video playback" media-video/mplayer
- optfeature "sound and video playback" media-video/mplayer2
optfeature "extraction of PDF page titles" app-text/pdftk
}
diff --git a/app-office/impressive/metadata.xml b/app-office/impressive/metadata.xml
index 053061c0eeb8..cf4e5cb4688e 100644
--- a/app-office/impressive/metadata.xml
+++ b/app-office/impressive/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>