summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/wps-office/Manifest2
-rw-r--r--app-office/wps-office/wps-office-10.1.0.6758.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/app-office/wps-office/Manifest b/app-office/wps-office/Manifest
index 06e875aabf8a..54d1f8c967c5 100644
--- a/app-office/wps-office/Manifest
+++ b/app-office/wps-office/Manifest
@@ -1,2 +1,4 @@
DIST wps-office_10.1.0.6757_x86.tar.xz 134095644 BLAKE2B ad44db7aa752055b59a52870041aa4c16d146e3068a8d95c8939efcc979a514a3ae6fcde1bca5eb90833c47c051295722e547316337c5f56727252cae133b994 SHA512 ba5001f0fd2a605c3688084d34aa293a728ac46d52379cea6db8c5232c4331e60476d5845087002071f89ec9d8bdf7c020222b4aaff780736eaeff5a273f40ee
DIST wps-office_10.1.0.6757_x86_64.tar.xz 131336404 BLAKE2B dfaa30f643d9fb08db711cd4ddec76ad3c10bc5435f4c6a2b245b9232059a22f918364e585c9a9551612ee10eff1535a44b5f300a8863f39d4cabb2f7c76b467 SHA512 5f9f88cc9795a317267531cb1cd260d86e1613dc5eef34005eaa58dd8ac0715ce3ba1da60ee83c617cb16d759b0da9274963f8a4fb4a86c4890eca0565af9c62
+DIST wps-office_10.1.0.6758_x86.tar.xz 134090056 BLAKE2B b137774b23c947cf81e3c3b4bdde105285c415ae18c14ed6e11ab72d10287ec7129b63c17c73494c146da94d5df0c266f7bc4b7490f6740ff0cb89c99d89f2d2 SHA512 ed1a59e3abfdda71025eacfd6eb6f699459ce815894232ca6205990f4de5cb7a51c958a354edb01b6411ffba691aa03c839720f156ea467c018e005dcc795d75
+DIST wps-office_10.1.0.6758_x86_64.tar.xz 131332480 BLAKE2B 030474fe48d392f6b8d00da19b8be97e5e19414cac64567c563d6dfc79a89e40ef7cdf0551219bada63661a69aa23ba3bfa8a808d41d0fa6f4c61e61b0871678 SHA512 2e1510d79119a4950437023ec34199e3e6e5ddc43e655af0cc0993758f640887395771ca27a4eec1bb9e81788738221d135d652feda988b6a3194090229c9cfd
diff --git a/app-office/wps-office/wps-office-10.1.0.6758.ebuild b/app-office/wps-office/wps-office-10.1.0.6758.ebuild
new file mode 100644
index 000000000000..4859d63427b3
--- /dev/null
+++ b/app-office/wps-office/wps-office-10.1.0.6758.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg
+
+MY_PV="$(ver_cut 4)"
+
+case ${ARCH} in
+ amd64)
+ MY_P="${PN}_${PV}_x86_64"
+ ;;
+ x86)
+ MY_P="${PN}_${PV}_x86"
+ ;;
+esac
+
+DESCRIPTION="WPS Office is an office productivity suite"
+HOMEPAGE="http://www.wps.cn/product/wpslinux/ http://wps-community.org/"
+
+KEYWORDS="~amd64 ~x86"
+
+SRC_URI="
+ amd64? ( http://kdl.cc.ksosoft.com/wps-community/download/${MY_PV}/${PN}_${PV}_x86_64.tar.xz )
+ x86? ( http://kdl.cc.ksosoft.com/wps-community/download/${MY_PV}/${PN}_${PV}_x86.tar.xz )
+"
+
+SLOT="0"
+RESTRICT="strip mirror" # mirror as explained at bug #547372
+LICENSE="WPS-EULA"
+IUSE=""
+
+# Deps got from this (listed in order):
+# rpm -qpR wps-office-10.1.0.5707-1.a21.x86_64.rpm
+# ldd /opt/kingsoft/wps-office/office6/wps
+# ldd /opt/kingsoft/wps-office/office6/wpp
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ dev-libs/glib:2
+ sys-libs/zlib:0
+ net-print/cups
+ media-libs/libpng:1.2
+ virtual/glu
+
+ dev-libs/libpcre:3
+ dev-libs/libffi
+ media-sound/pulseaudio
+ app-arch/bzip2:0
+ media-libs/libpng:0
+ dev-libs/expat
+ sys-apps/util-linux
+ dev-libs/libbsd
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ sys-apps/dbus
+ x11-libs/libXtst
+ sys-apps/tcp-wrappers
+ media-libs/libsndfile
+ net-libs/libasyncns
+ dev-libs/libgcrypt:0
+ app-arch/xz-utils
+ app-arch/lz4
+ sys-libs/libcap
+ media-libs/flac
+ media-libs/libogg
+ media-libs/libvorbis
+ dev-libs/libgpg-error
+ sys-apps/attr
+"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+#src_prepare() {
+# default
+ # We need to drop qtwebkit bundled lib completely because it causes
+ # crashes in *some* setups (https://bugs.gentoo.org/647950)
+# rm -f "${S}"/opt/kingsoft/wps-office/office6/libQtWebKit* || die
+#}
+
+src_install() {
+ exeinto /usr/bin
+ exeopts -m0755
+ doexe "${S}"/wps
+ doexe "${S}"/wpp
+ doexe "${S}"/et
+
+ insinto /usr/share
+ doins -r "${S}"/resource/{applications,icons,mime}
+
+ insinto /opt/kingsoft/wps-office
+ doins -r "${S}"/office6
+
+ fperms 0755 /opt/kingsoft/wps-office/office6/{wps,wpp,et}
+}