summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild')
-rw-r--r--app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild b/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild
new file mode 100644
index 000000000000..e6f9bbcd8cfb
--- /dev/null
+++ b/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+# tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/2" # based on SONAME of libusbmuxd.so
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="kernel_linux static-libs"
+
+RDEPEND=">=app-pda/libplist-1.11:=
+ virtual/libusb:1
+ !=app-pda/usbmuxd-1.0.9
+ !<app-pda/usbmuxd-1.0.8_p1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+ local myeconfargs=( $(use_enable static-libs static) )
+ use kernel_linux || myeconfargs+=( --without-inotify )
+
+ autotools-utils_src_configure
+}