summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch')
-rw-r--r--app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch b/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch
new file mode 100644
index 000000000000..042b948b23d7
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch
@@ -0,0 +1,35 @@
+From b70919e0d9dadc93893e9d18bc3ef13b88756ecf Mon Sep 17 00:00:00 2001
+From: dana <dana@dana.is>
+Date: Sun, 27 Jan 2019 00:26:31 -0600
+Subject: [PATCH] 44020: VCS_INFO_detect_p4: Fix infinite recursion
+
+---
+ ChangeLog | 5 +++++
+ Functions/VCS_Info/Backends/VCS_INFO_detect_p4 | 1 -
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index 81668ccc9..be243c1b8 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,8 @@
++2018-01-27 dana <dana@dana.is>
++
++ * 44020: Functions/VCS_Info/Backends/VCS_INFO_detect_p4: Fix
++ infinite recursion
++
+ 2018-01-24 dana <dana@dana.is>
+
+ * unposted: Config/version.mk: Post-release version bump
+diff --git a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4 b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+index d171c68ee..5ec21da9f 100644
+--- a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
++++ b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+@@ -44,7 +44,6 @@ VCS_INFO_p4_get_server() {
+ }
+
+
+-(( ${+functions[VCS_INFO_detect_p4]} )) ||
+ VCS_INFO_detect_p4() {
+ local serverport p4where
+