summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/z/Manifest1
-rw-r--r--app-shells/z/metadata.xml13
-rw-r--r--app-shells/z/z-1.9.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/app-shells/z/Manifest b/app-shells/z/Manifest
new file mode 100644
index 000000000000..4f551bd05edc
--- /dev/null
+++ b/app-shells/z/Manifest
@@ -0,0 +1 @@
+DIST z-1.9.tar.gz 5894 SHA256 28aaff75254c8914063ce2534a4b882845054701230475b11dba6d7a305d82c9 SHA512 8e22c04075d502dfbb0225518c923065347aa842d463237e927c2f9e4c6a2c5d211cd43c06a374f078090b4418849afdfabd6a3d249e9c35f9423dffe8078733 WHIRLPOOL 21a7d5e10b69b2f898254fd89f7be42aea1364fd81604d17bf58e244ce8a0a4b6cc92b41062eb008304522cf9623a50745dda7d9466a1a8a1fe3a8a8e5cac4f4
diff --git a/app-shells/z/metadata.xml b/app-shells/z/metadata.xml
new file mode 100644
index 000000000000..ad3df7c0d9b7
--- /dev/null
+++ b/app-shells/z/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ Tracks your most used directories, based on 'frecency'. After a short
+ learning phase, z will take you to the most 'frecent' directory that
+ matches ALL of the regexes given on the command line, in order.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-shells/z/z-1.9.ebuild b/app-shells/z/z-1.9.ebuild
new file mode 100644
index 000000000000..f107e3c0a52a
--- /dev/null
+++ b/app-shells/z/z-1.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Change directory command that learns visited paths"
+HOMEPAGE="https://github.com/rupa/z/"
+SRC_URI="https://github.com/rupa/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/rupa-z-5dc2a86"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/${PN}/"
+ doins z.sh
+ doman z.1
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To enable 'z' command you need to source /usr/share/${PN}/z.sh."
+ elog "Add following line to your ~/.bashrc, ~/.zshrc or equivalent"
+ elog "in other shells:"
+ elog ""
+ elog " [ -r /usr/share/${PN}/z.sh ] && . /usr/share/${PN}/z.sh"
+ elog ""
+ elog "See z(1) man page for usage and configuration options."
+ fi
+}