summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cmark/cmark-0.30.1.ebuild')
-rw-r--r--app-text/cmark/cmark-0.30.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/app-text/cmark/cmark-0.30.1.ebuild b/app-text/cmark/cmark-0.30.1.ebuild
deleted file mode 100644
index 6dff7a3f62ca..000000000000
--- a/app-text/cmark/cmark-0.30.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="CommonMark parsing and rendering library and program in C"
-HOMEPAGE="https://github.com/commonmark/cmark"
-SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMARK_LIB_FUZZER=OFF
- -DCMARK_SHARED=ON
- -DCMARK_STATIC=OFF
- -DCMARK_TESTS="$(usex test)"
- )
- cmake_src_configure
-}