summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/namazu/namazu-2.0.21.ebuild')
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index 5d0b4d0d14e3..ef46e76118df 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit autotools elisp-common
@@ -9,7 +9,7 @@ DESCRIPTION="Namazu is a full-text search engine"
HOMEPAGE="http://www.namazu.org/"
SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE="emacs l10n_ja nls static-libs tk"
@@ -30,11 +30,12 @@ RDEPEND="dev-perl/File-MMagic
dev-lang/tk:0
www-client/lynx
)"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-emacs-27.patch
"${FILESDIR}"/${PN}-perl-5.18.patch
"${FILESDIR}"/${PN}-perl-5.26.patch
"${FILESDIR}"/${P}-memmove.patch
@@ -43,8 +44,8 @@ PATCHES=(
src_prepare() {
default
- mv configure.{in,ac}
- mv tk${PN}/configure.{in,ac}
+ mv configure.{in,ac} || die
+ mv tk${PN}/configure.{in,ac} || die
eautoreconf
}
@@ -64,7 +65,7 @@ src_configure() {
}
src_compile() {
- emake
+ default
if use emacs; then
cd lisp