summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/breakpts/breakpts-4.0-r2.ebuild')
-rw-r--r--app-vim/breakpts/breakpts-4.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/breakpts/breakpts-4.0-r2.ebuild b/app-vim/breakpts/breakpts-4.0-r2.ebuild
new file mode 100644
index 000000000000..1dcdff18bc43
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=618"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=8142 -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+DEPEND="app-arch/unzip"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."