summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/gentoo-syntax/gentoo-syntax-20210901.ebuild')
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20210901.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20210901.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20210901.ebuild
deleted file mode 100644
index 72f25ef766b6..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-20210901.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}