summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gitgutter/Manifest1
-rw-r--r--app-vim/gitgutter/gitgutter-20160916.ebuild24
-rw-r--r--app-vim/gitgutter/gitgutter-99999999.ebuild3
3 files changed, 27 insertions, 1 deletions
diff --git a/app-vim/gitgutter/Manifest b/app-vim/gitgutter/Manifest
index 8e37262f8829..43d443d66b75 100644
--- a/app-vim/gitgutter/Manifest
+++ b/app-vim/gitgutter/Manifest
@@ -1 +1,2 @@
DIST gitgutter-20160316.tar.bz2 37102 SHA256 41d3e44ae569cf208682e0e50b30bef669e195ad048196ec8fc91a9d8496637a SHA512 f63bb92097c1c52d5a6d84d9707358d4c3c681b1e7b5f4cc19846cda0ee5938d7f0180d5f9dcf259f06d32839e64ebbc4d7b4b681fc91cc785e484fba7d4c1b7 WHIRLPOOL 45a7fcb9108eeab47fdd2cfcc2f9409335d5b322d7bb1db58d9b702583b384d9c9a7ac7084620de1ce2a99370e87b29063291c8aee87c6710bf2153289afc003
+DIST gitgutter-20160916.tar.bz2 40664 SHA256 28927a857a3f37bd2d3348b6bec8d5b7fec856a5b96b06b3bcd80275ef402314 SHA512 7e3724f6b4845d4b1cbb75edecf6b1701ebd174e808a7db69930dda6913b8552d3bb1d366973198768df78ba4978b20ddab360ee4988498f30107dfe7fc1102f WHIRLPOOL a7e01d887dea3aacde7f27e9cdc9f45c7abb7928164508044e6c86f2e8380557a39a455ad57dedb360dd9339c78034abb1e815f50cc694ee799d6336088722e2
diff --git a/app-vim/gitgutter/gitgutter-20160916.ebuild b/app-vim/gitgutter/gitgutter-20160916.ebuild
new file mode 100644
index 000000000000..975c09c94034
--- /dev/null
+++ b/app-vim/gitgutter/gitgutter-20160916.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
+HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm README* screenshot.png || die
+ rm -rf test || die
+}
diff --git a/app-vim/gitgutter/gitgutter-99999999.ebuild b/app-vim/gitgutter/gitgutter-99999999.ebuild
index 6ae5ba5443f6..975c09c94034 100644
--- a/app-vim/gitgutter/gitgutter-99999999.ebuild
+++ b/app-vim/gitgutter/gitgutter-99999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == 9999* ]]; then
@@ -18,6 +18,7 @@ LICENSE="MIT"
VIM_PLUGIN_HELPFILES="${PN}.txt"
src_prepare() {
+ default
rm README* screenshot.png || die
rm -rf test || die
}