summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/syntastic/Manifest1
-rw-r--r--app-vim/syntastic/syntastic-3.8.0.ebuild34
-rw-r--r--app-vim/syntastic/syntastic-9999.ebuild5
3 files changed, 38 insertions, 2 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
index 4322f6284993..cdeec38aab56 100644
--- a/app-vim/syntastic/Manifest
+++ b/app-vim/syntastic/Manifest
@@ -1 +1,2 @@
DIST syntastic-3.7.0.tar.gz 198480 SHA256 4006fdd5e786ceeb493817c2b6b0d1e6a403089436c958239359a3e7fb7ab016 SHA512 c435969a6c309d303bdd74c87cad25df56cd30028a75be8e58f035e6dd00b0390654ff2ee8e552a1a2495054426b9f43ea7f7db45691e6bddf9783ee0a4ccb73 WHIRLPOOL 26c3258cbbdd3e4cc637c79cf2f3c53d87322b35a3c0d89021e925e10a5006b87ff2ecc3202983365dd4e5b0489ac4e0da44211fd61edff945ebd7c6efd36002
+DIST syntastic-3.8.0.tar.gz 253425 SHA256 aa46913abdfa35dfbd9f022d084680b375bf43b32b409378f4a697ab576a5673 SHA512 b2f7fb07d457169a397a1ed42141e099cad14ded0b43f54a11060f2952843387396fcc539ffc9aaa1aa137ae62801e346a73c6de6035a0504706c59e40acef5c WHIRLPOOL 3f061793e89e54b1c267b34e5e70ca5edd1fecbc0d042ac4f716a065e66663bc27fd3b62f480bdc8e4084e6e4a145618eec4a1b58ad61426d270c7c9186d8e0c
diff --git a/app-vim/syntastic/syntastic-3.8.0.ebuild b/app-vim/syntastic/syntastic-3.8.0.ebuild
new file mode 100644
index 000000000000..5e820632ae04
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ default
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}
diff --git a/app-vim/syntastic/syntastic-9999.ebuild b/app-vim/syntastic/syntastic-9999.ebuild
index be5b783accd2..5e820632ae04 100644
--- a/app-vim/syntastic/syntastic-9999.ebuild
+++ b/app-vim/syntastic/syntastic-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == "9999" ]] ; then
@@ -20,6 +20,7 @@ LICENSE="WTFPL-2"
VIM_PLUGIN_HELPFILES="${PN}"
src_prepare() {
+ default
rm -r _assets LICENCE README.markdown || die
}