summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ada/aunit/aunit-2020.ebuild')
-rw-r--r--dev-ada/aunit/aunit-2020.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ada/aunit/aunit-2020.ebuild b/dev-ada/aunit/aunit-2020.ebuild
deleted file mode 100644
index 4bf0db12dc93..000000000000
--- a/dev-ada/aunit/aunit-2020.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_201{7..9} )
-inherit ada multiprocessing
-
-MYP=${P}-20200429-19B6C-src
-
-DESCRIPTION="Ada unit testing framework"
-HOMEPAGE="http://libre.adacore.com/tools/aunit/"
-SRC_URI="https://community.download.adacore.com/v1/6c8702d4a3c4a39f5da077716e44bef980377ba8?filename=${MYP}.tar.gz
- -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
-
-src_compile() {
- emake GPRBUILD="gprbuild -j$(makeopts_jobs) -v"
-}
-
-src_install() {
- emake INSTALL="${D}"/usr install
- einstalldocs
- mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
- rmdir "${D}"/usr/share/doc/${PN} || die
- mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
- rmdir "${D}"/usr/share/examples || die
- rm -r "${D}"/usr/share/gpr/manifests || die
-}
-
-src_test() {
- emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
-}