summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/gqlplus')
-rw-r--r--dev-db/gqlplus/Manifest1
-rw-r--r--dev-db/gqlplus/gqlplus-1.16.ebuild29
-rw-r--r--dev-db/gqlplus/metadata.xml14
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/gqlplus/Manifest b/dev-db/gqlplus/Manifest
new file mode 100644
index 000000000000..16529f89345b
--- /dev/null
+++ b/dev-db/gqlplus/Manifest
@@ -0,0 +1 @@
+DIST gqlplus-1.16.tar.gz 2128428 SHA256 9e0071d6f8bc24b0b3623c69d9205f7d3a19c2cb32b5ac9cff133dc75814acdd SHA512 e9d7685e4db741db8232f7ba7a05df59042d0cafe198060adcd37aea2d3878e785eacb1f7b72fcb154558d1be8c619818dbeceffaefb75e372a18ed23e234512 WHIRLPOOL d4c06fce8774c4f6ad6a37e7c48f7720fef8cf4fb40997ff2ae14e148a5e3d6cab4c293d5ea7a4888d4764233707a8845dfac8862bab960f40f6163e7d914d8f
diff --git a/dev-db/gqlplus/gqlplus-1.16.ebuild b/dev-db/gqlplus/gqlplus-1.16.ebuild
new file mode 100644
index 000000000000..b6ab36df836f
--- /dev/null
+++ b/dev-db/gqlplus/gqlplus-1.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="a front-end for Oracle program sqlplus with command-line editing"
+HOMEPAGE="https://sourceforge.net/projects/gqlplus/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos"
+IUSE=""
+
+DEPEND="sys-libs/readline:*"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # don't use packaged readline and old version containing it
+ rm -Rf readline gqlplus-1.15
+
+ # maintainer can't seem to get versioning right
+ sed -i '/^#define VERSION/s/"[^"]\+"/"'"${PV}"'"/' gqlplus.c || die
+ sed -i '/^AC_INIT/s/\[[1-9.]\+\]/['"${PV}"']/' configure.ac || die
+ eautoreconf
+}
diff --git a/dev-db/gqlplus/metadata.xml b/dev-db/gqlplus/metadata.xml
new file mode 100644
index 000000000000..a9b0f077fa7f
--- /dev/null
+++ b/dev-db/gqlplus/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <longdescription lang="en">
+ gqlplus is a front-end for Oracle program sqlplus with
+ command-line editing, history, table-name and column-name
+ completion. Otherwise the user interface is identical to that of
+ sqlplus. Command-line editing works as in bash/tcsh shells.
+ </longdescription>
+</pkgmetadata>