summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild')
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
new file mode 100644
index 000000000000..48a310773ffe
--- /dev/null
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit mono eutils multilib
+
+S="${WORKDIR}/MonoCalendar"
+
+DESCRIPTION="iCal clone for .NET"
+HOMEPAGE="http://www.monocalendar.com/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.2.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"/bin/Release/
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/${PN}
+ insinto /usr/$(get_libdir)/${PN}
+
+ doins bin/Release/*dll
+ doins bin/Release/*.exe
+
+ make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
+}