summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild')
-rw-r--r--dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild
new file mode 100644
index 000000000000..b71c3d759edd
--- /dev/null
+++ b/dev-haskell/concurrent-extra/concurrent-extra-0.7.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile test-suite" # haddock fails for strange reason
+inherit haskell-cabal
+
+DESCRIPTION="Extra concurrency primitives"
+HOMEPAGE="https://github.com/basvandijk/concurrent-extra"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-unicode-symbols-0.1.1:=[profile?] <dev-haskell/base-unicode-symbols-0.3:=[profile?]
+ >=dev-haskell/stm-2.1.2.1:=[profile?] <dev-haskell/stm-2.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?] <dev-haskell/unbounded-delays-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/async-2.0 <dev-haskell/async-2.1
+ >=dev-haskell/hunit-1.2.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/random-1.0 <dev-haskell/random-1.1
+ >=dev-haskell/test-framework-0.2.4 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.4 <dev-haskell/test-framework-hunit-0.4 )
+"