summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/conduit/conduit-1.2.5.ebuild')
-rw-r--r--dev-haskell/conduit/conduit-1.2.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/conduit/conduit-1.2.5.ebuild b/dev-haskell/conduit/conduit-1.2.5.ebuild
new file mode 100644
index 000000000000..31d72979df21
--- /dev/null
+++ b/dev-haskell/conduit/conduit-1.2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Streaming data processing library"
+HOMEPAGE="http://github.com/snoyberg/conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/exceptions-0.6:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ dev-haskell/mmorph:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/transformers-base-0.4.1:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/safe )
+"
+
+src_prepare() {
+ # https://ghc.haskell.org/trac/ghc/ticket/10665
+ [[ $(ghc-version) == 7.10.1.20150630 ]] && replace-hcflags -g ''
+ [[ $(ghc-version) == 7.10.2 ]] && replace-hcflags -g ''
+}