summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/crypto-api/crypto-api-0.13.ebuild')
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/crypto-api/crypto-api-0.13.ebuild b/dev-haskell/crypto-api/crypto-api-0.13.ebuild
new file mode 100644
index 000000000000..abfe3fdef173
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}