summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/email-validate/email-validate-1.0.0.ebuild')
-rw-r--r--dev-haskell/email-validate/email-validate-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/email-validate/email-validate-1.0.0.ebuild b/dev-haskell/email-validate/email-validate-1.0.0.ebuild
new file mode 100644
index 000000000000..c377625ab40f
--- /dev/null
+++ b/dev-haskell/email-validate/email-validate-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Validating an email address string against RFC 5322"
+HOMEPAGE="http://porg.es/blog/email-address-validation-simpler-faster-more-correct"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/hunit-1.2
+ <dev-haskell/hunit-2
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4.1
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )
+ >=dev-haskell/cabal-1.8"