summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/encoding/encoding-0.8.ebuild')
-rw-r--r--dev-haskell/encoding/encoding-0.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/encoding/encoding-0.8.ebuild b/dev-haskell/encoding/encoding-0.8.ebuild
new file mode 100644
index 000000000000..7c7ea0488f3a
--- /dev/null
+++ b/dev-haskell/encoding/encoding-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A library for various character encodings"
+HOMEPAGE="http://code.haskell.org/encoding/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+systemencoding"
+
+RDEPEND="<dev-haskell/binary-0.8:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/haxml-1.22:=[profile?] <dev-haskell/haxml-1.26:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag systemencoding systemencoding)
+}