summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/exceptions/exceptions-0.8.0.2.ebuild')
-rw-r--r--dev-haskell/exceptions/exceptions-0.8.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild b/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild
new file mode 100644
index 000000000000..8b48cf9806fb
--- /dev/null
+++ b/dev-haskell/exceptions/exceptions-0.8.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extensible optionally-pure exceptions"
+HOMEPAGE="http://github.com/ekmett/exceptions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/stm-2.2:=[profile?] <dev-haskell/stm-3:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.5:2
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.5 && < 2.8' 'QuickCheck >= 2.5'
+}