summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/glob/glob-0.7.5.ebuild')
-rw-r--r--dev-haskell/glob/glob-0.7.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/glob/glob-0.7.5.ebuild b/dev-haskell/glob/glob-0.7.5.ebuild
new file mode 100644
index 000000000000..326212aa6798
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.8:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'filepath >= 1.1 && < 1.4' 'filepath >= 1.1'
+}