summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/juicypixels/juicypixels-3.1.7.1.ebuild')
-rw-r--r--dev-haskell/juicypixels/juicypixels-3.1.7.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/juicypixels/juicypixels-3.1.7.1.ebuild b/dev-haskell/juicypixels/juicypixels-3.1.7.1.ebuild
new file mode 100644
index 000000000000..e98d54f843fd
--- /dev/null
+++ b/dev-haskell/juicypixels/juicypixels-3.1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="JuicyPixels"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Picture loading/serialization (in png, jpeg, bitmap, gif, tiff and radiance)"
+HOMEPAGE="https://github.com/Twinside/Juicy.Pixels"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmap"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/primitive-0.4:=[profile?] <dev-haskell/primitive-0.6:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-0.5.3.1:=[profile?] <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ mmap? ( dev-haskell/mmap:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag mmap mmap)
+}