summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/language-javascript/language-javascript-0.5.13.3.ebuild')
-rw-r--r--dev-haskell/language-javascript/language-javascript-0.5.13.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/language-javascript/language-javascript-0.5.13.3.ebuild b/dev-haskell/language-javascript/language-javascript-0.5.13.3.ebuild
new file mode 100644
index 000000000000..27d5f0b3f350
--- /dev/null
+++ b/dev-haskell/language-javascript/language-javascript-0.5.13.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parser for JavaScript"
+HOMEPAGE="http://github.com/alanz/language-javascript"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?]
+ >=dev-haskell/utf8-string-0.3.7:=[profile?] <dev-haskell/utf8-string-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.9.2
+ dev-haskell/happy
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/utf8-light-0.4 )
+"