summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/opengl/opengl-2.9.2.0.ebuild')
-rw-r--r--dev-haskell/opengl/opengl-2.9.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/opengl/opengl-2.9.2.0.ebuild b/dev-haskell/opengl/opengl-2.9.2.0.ebuild
new file mode 100644
index 000000000000..6937750d2aa0
--- /dev/null
+++ b/dev-haskell/opengl/opengl-2.9.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+MY_PN="OpenGL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/gluraw-1.3.0.0:=[profile?]
+ >=dev-haskell/openglraw-1.4.1.0:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}