summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/reflection/reflection-1.5.1.ebuild')
-rw-r--r--dev-haskell/reflection/reflection-1.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/reflection/reflection-1.5.1.ebuild b/dev-haskell/reflection/reflection-1.5.1.ebuild
new file mode 100644
index 000000000000..c44a9795e8c5
--- /dev/null
+++ b/dev-haskell/reflection/reflection-1.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+#hackport: flags: -slow
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Reifies arbitrary terms into types that can be reflected back into terms"
+HOMEPAGE="http://github.com/ekmett/reflection"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+th"
+
+RDEPEND=">=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-slow \
+ $(cabal_flag th th)
+}