summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild')
-rw-r--r--dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild b/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild
new file mode 100644
index 000000000000..76411ef52b5d
--- /dev/null
+++ b/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Jakarta-Commons Primitives Component"
+HOMEPAGE="http://commons.apache.org/primitives/"
+SRC_URI="mirror://apache/jakarta/commons/primitives/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+# Would need an old version of commons-collections and this would be the
+# only user. Trunk works against the latest version so hopefully they will
+# have a new release at some point.
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/docs/api
+ use source && java-pkg_dosrc src/java/*
+}