summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pigpio/pigpio-76.ebuild')
-rw-r--r--dev-libs/pigpio/pigpio-76.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/pigpio/pigpio-76.ebuild b/dev-libs/pigpio/pigpio-76.ebuild
new file mode 100644
index 000000000000..a47a53d9b909
--- /dev/null
+++ b/dev-libs/pigpio/pigpio-76.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/ https://github.com/joan2937/pigpio"
+SRC_URI="https://github.com/joan2937/pigpio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}/${PN}-70-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+ libdir="${EPREFIX}/usr/$(get_libdir)" prefix="${EPREFIX}/usr" \
+ mandir="${EPREFIX}/usr/share/man" install
+ einstalldocs
+ newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+ newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+ systemd_newunit "${S}"/util/pigpiod.service pigpiod.service
+ use python && distutils-r1_src_install
+}