summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Text_Wiki_Mediawiki')
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/Manifest1
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild26
-rw-r--r--dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch36
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest b/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
index fe45a7e001e6..730da51fc7f1 100644
--- a/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/Manifest
@@ -1 +1,2 @@
DIST Text_Wiki_Mediawiki-0.2.0.tgz 17022 BLAKE2B e43d7452f28ebd8d730f69d947ed19bc47eeb2a40b5b7a99be1868d0bf8daa57b91fe7bd27adad49334999ce181f4254bfbe3b7f091d6dd34ac603a2108a6582 SHA512 032d1fb229b4e2ab65f60c90cc5a234b441093837c9d7170477f04e591a15c9a891baf9f45171275f152a358616124729db7edc97def2c72cfddf498b48f17a4
+DIST Text_Wiki_Mediawiki-0.2.0_p20140604.tar.gz 22941 BLAKE2B d208b4df7e01a2b28e44ada0226be0f183fe6ffefe742f9b6cb4f2b366f915ae46d950d574a8357cbec273f41792f17a639f5512613628ee60ed137d909be9dd SHA512 aef4d18a4a0b9f41dc4bad701a90a2e7d674851b63206db9dd87cf87d6705991c8221e41cdbb8d2572a950520ce87db96105a009e4189e48b8e7f5df0f460ee5
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild b/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
new file mode 100644
index 000000000000..ad7c16118923
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/PEAR-Text_Wiki_Mediawiki-0.2.0_p20140604.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+SRC_URI="https://github.com/pear/Text_Wiki_Mediawiki/archive/11a902741d3f8cc6010fb97b825d66345143e4dc.tar.gz -> ${PEAR_P}.tar.gz"
+DESCRIPTION="Mediawiki parser for Text_Wiki"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RDEPEND=">=dev-php/PEAR-Text_Wiki-1.2.2_p20170904"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+PATCHES=( "${FILESDIR}/0.2.0-constructor.patch" )
+
+src_test() {
+ phpunit tests/Text_Wiki_Parse_Mediawiki_Test.php || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/.packagexml
+ newins package.xml "${PEAR_P}.xml"
+}
diff --git a/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch b/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
new file mode 100644
index 000000000000..edd8e3572de0
--- /dev/null
+++ b/dev-php/PEAR-Text_Wiki_Mediawiki/files/0.2.0-constructor.patch
@@ -0,0 +1,36 @@
+diff -aurN a/Text/Wiki/Mediawiki.php b/Text/Wiki/Mediawiki.php
+--- a/Text/Wiki/Mediawiki.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Mediawiki.php 2018-02-14 13:36:18.777893414 -0500
+@@ -87,7 +87,7 @@
+ * @param array $rules The set of rules to load for this object.
+ */
+ function __construct($rules = null) {
+- parent::Text_Wiki($rules);
++ parent::__construct($rules);
+ $this->addPath('parse', $this->fixPath(dirname(__FILE__)).'Parse/Mediawiki');
+ }
+ }
+diff -aurN a/Text/Wiki/Parse/Mediawiki/Url.php b/Text/Wiki/Parse/Mediawiki/Url.php
+--- a/Text/Wiki/Parse/Mediawiki/Url.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Parse/Mediawiki/Url.php 2018-02-14 13:40:21.974024459 -0500
+@@ -87,7 +87,7 @@
+ */
+ function __construct(&$obj)
+ {
+- parent::Text_Wiki_Parse($obj);
++ parent::__construct($obj);
+
+ // convert the list of recognized schemes to a regex-safe string,
+ // where the pattern delim is a slash
+diff -aurN a/Text/Wiki/Parse/Mediawiki/Wikilink.php b/Text/Wiki/Parse/Mediawiki/Wikilink.php
+--- a/Text/Wiki/Parse/Mediawiki/Wikilink.php 2014-06-04 23:24:45.000000000 -0400
++++ b/Text/Wiki/Parse/Mediawiki/Wikilink.php 2018-02-14 13:40:46.030542359 -0500
+@@ -99,7 +99,7 @@
+ function __construct(&$obj)
+ {
+ $default = $this->conf;
+- parent::Text_Wiki_Parse($obj);
++ parent::__construct($obj);
+
+ // override config options for image if specified
+ if (in_array('Image', $this->wiki->disable)) {