summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/cphplib')
-rw-r--r--dev-php/cphplib/cphplib-0.51-r1.ebuild29
-rw-r--r--dev-php/cphplib/files/constructor.patch42
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-php/cphplib/cphplib-0.51-r1.ebuild b/dev-php/cphplib/cphplib-0.51-r1.ebuild
new file mode 100644
index 000000000000..c79a4a612094
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Cute PHP Library (cphplib)"
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cphplib/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-php/PEAR-DB-1.7.6-r1"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/constructor.patch" )
+
+src_install() {
+ local DOCS=( ChangeLog README TODO )
+ local -a HTML_DOCS
+ insinto "/usr/share/php/${PN}"
+ doins -r i18n cphplib_formular.inc cphplib.inc
+ use doc && HTML_DOCS=( doc/packages.html doc/blank.html
+ doc/classtrees_cphplib.html doc/index.html doc/cphplib/
+ doc/errors.html doc/__filesource/ doc/elementindex.html
+ doc/li_cphplib.html doc/elementindex_cphplib.html doc/media/ )
+ einstalldocs
+}
diff --git a/dev-php/cphplib/files/constructor.patch b/dev-php/cphplib/files/constructor.patch
new file mode 100644
index 000000000000..1ab88d212c1f
--- /dev/null
+++ b/dev-php/cphplib/files/constructor.patch
@@ -0,0 +1,42 @@
+diff -uarN a/cphplib_formular.inc b/cphplib_formular.inc
+--- a/cphplib_formular.inc 2006-05-25 05:03:44.000000000 -0400
++++ b/cphplib_formular.inc 2017-07-27 10:49:10.928727081 -0400
+@@ -130,6 +130,11 @@
+
+ function cphplib_formular($locale="de_DE")
+ {
++ __construct($locale);
++ }
++
++ function __construct($locale="de_DE")
++ {
+ parent::cphplib($locale);
+
+ $this->os_type = $this->os_type();
+@@ -1390,4 +1395,3 @@
+ }
+ }
+
+-?>
+\ No newline at end of file
+diff -uarN a/cphplib.inc b/cphplib.inc
+--- a/cphplib.inc 2006-05-25 05:03:58.000000000 -0400
++++ b/cphplib.inc 2017-07-27 10:59:51.910098156 -0400
+@@ -215,6 +215,11 @@
+ */
+ function cphplib($locale="de_DE")
+ {
++ __construct($locale);
++ }
++
++ function __construct($locale="de_DE")
++ {
+ if (!empty($locale))
+ {
+ $this->locale = $locale;
+@@ -4539,4 +4544,3 @@
+ }
+ }
+
+-?>
+\ No newline at end of file