summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/doctrine-instantiator/doctrine-instantiator-1.1.0.ebuild')
-rw-r--r--dev-php/doctrine-instantiator/doctrine-instantiator-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/doctrine-instantiator/doctrine-instantiator-1.1.0.ebuild b/dev-php/doctrine-instantiator/doctrine-instantiator-1.1.0.ebuild
new file mode 100644
index 000000000000..9ca2b9c37c06
--- /dev/null
+++ b/dev-php/doctrine-instantiator/doctrine-instantiator-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/doctrine-//}"
+
+DESCRIPTION="Utility to instantiate objects in PHP without invoking their constructors"
+HOMEPAGE="https://github.com/doctrine/${MY_PN}"
+SRC_URI="https://github.com/doctrine/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r src/*
+ insinto /usr/share/php/Doctrine/Instantiator
+ doins "${FILESDIR}/autoload.php"
+}