summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/Manifest1
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.4.ebuild66
-rw-r--r--dev-php/libvirt-php/libvirt-php-9999.ebuild2
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-php/libvirt-php/Manifest b/dev-php/libvirt-php/Manifest
index b96fab88e90b..ba9ddb371739 100644
--- a/dev-php/libvirt-php/Manifest
+++ b/dev-php/libvirt-php/Manifest
@@ -1 +1,2 @@
DIST libvirt-php-0.5.3.tar.gz 778604 BLAKE2B 40fe4bb2f1e3fd81f1aaf09b8b92c509e79186a1a6c0dc97aa55c7164ed36cc0088141ed46c3d82cf277e25eaf3b017edac9466684e1060b5a22c18aaa7a576f SHA512 b4cbfd8840d8f114fde762b5d6ada155ebdb231b554e28e8526a7af45a802a18f28e90fa52f3d7ca9f616996fe0a8289b70c2d14dca51a52a7bf8a501c3ff44f
+DIST libvirt-php-0.5.4.tar.gz 780793 BLAKE2B 8bb4577c26cc0ef8f2a0ae813ade7f5fdea9a2a7d70c97cab1033fde21d9a1c27b8c2ad7a8284096e143e955202bb564767b4d7e1a4bb9e15993895adc119288 SHA512 b5b204549e6810668203d1df8404a5cb71f646ae7e01ea223c6e9b9eec9b1f6500cc5bb4559859959d821a213ff992f22a97e4b683da2c683be3732710943487
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.4.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.4.ebuild
new file mode 100644
index 000000000000..12877cef46ef
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.5.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+PHP_EXT_ECONF_ARGS=()
+
+inherit php-ext-source-r3 autotools
+
+DESCRIPTION="PHP bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xhtml1 )"
+
+RESTRICT="test"
+# ChangeLog and NEWS are empty files
+DOCS=( AUTHORS README )
+# Remove the insane check for pecl-imagick which is only used in examples
+# and is not called upon in any build
+PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
+
+src_unpack() {
+ default
+
+ # create the default modules directory to be able
+ # to use the php-ext-source-r3 eclass to configure/build
+ ln -s src "${S}/modules"
+}
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ eautoreconf
+ done
+}
+
+src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ doins "src/.libs/${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r3_createinifiles
+ einstalldocs
+ if use doc ; then
+ docinto /usr/share/doc/${PF}/html
+ dodoc -r docs/*
+ fi
+}
diff --git a/dev-php/libvirt-php/libvirt-php-9999.ebuild b/dev-php/libvirt-php/libvirt-php-9999.ebuild
index 2943eb7e578a..862fc523ecbb 100644
--- a/dev-php/libvirt-php/libvirt-php-9999.ebuild
+++ b/dev-php/libvirt-php/libvirt-php-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PHP_EXT_NAME="libvirt-php"
PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php5-6 php7-0 php7-1"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
PHP_EXT_ECONF_ARGS=()
inherit php-ext-source-r3 git-r3 autotools